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The Geospatial Education and Outreach Project (GEO Project) is a collaborative effort among the Geosystems 
Research Institute (GRI), the Northern Gulf Institute (a NOAA Cooperative Institute), and the Mississippi State 
University Extension Service. The purpose of the project is to serve as the primary source for geospatial 
education and technical information for Mississippi. 

The GEO Project provides training and technical assistance in the use, application, and implementation of 
geographic information systems (GIS), remote sensing, and global positioning systems for the geospatial 
community of Mississippi. The purpose of the GEO Tutorial series is to support educational project activities and 
enhance geospatial workshops offered by the GEO Project. Each tutorial provides practical solutions and 
instructions to solve a particular GIS challenge. 
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REQUIRED RESOURCES 

• QGIS (3.16.9-Hannover) 

FEATURED DATA SOURCES 

• Sanborn Fire Insurance Map from Biloxi, Mississippi, May 1914. Map. Retrieved from the Library 
of Congress, <www.loc.gov/item/sanborn04432_005/>. 

OVERVIEW 

This tutorial focuses on georeferencing a raster dataset using QGIS. The fundamental idea behind 
georeferencing is to locate points on the non-georeferenced dataset to the same locations on a 
georeferenced dataset. The collection of X,Y pairs of points is called a ground control points (GCPs) table. 
After compiling a minimum of three GCPs, a first-order polynomial equation is created to spatially register 
the non-georeferenced dataset. The accurate and precise placement of GCPs, and spatially dispersed 
sampling of GCPs, has a significant impact on the final georeferenced product.  

To perform the steps listed below, you will use a historic fire insurance map from Biloxi, Mississippi as a 
non-georeferenced dataset, and an OpenStreetMap (OSM) standard basemap as a georeferenced dataset 
to locate your GCPs. Scanned historic maps are textbook examples of raster datasets that very often do 
not have a spatial reference defined. This means that they will not overlap with other spatial datasets 
unless they are georeferenced. The steps presented in this tutorial will illustrate how to define the spatial 
reference for a raster dataset based on the freely available web basemap.  
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STEP 1. DOWNLOAD THE SANBORN FIRE INSURANCE MAP 

A. Visit the Library of Congress Sanborn Maps collection and access Image 1 of Sanborn Fire 
Insurance Map from Biloxi, Mississippi, May 1914 using the following link:
http://www.loc.gov/resource/g3984bm.g3984bm_g044321914/?sp=1

B. Familiarize yourself with the map. Simply, pan around the image, zoom in and out to see map 
details such as street names, parcel numbers, and legend.

C. Scroll down to the download menu available in the lower-left corner and from the drop-down list 
select the JEPG2000 format. Click Go to download the file.

D. Save the image to your local drive, preferably to a folder where you will store all files created in
this tutorial. Rename the image to give it a shorter file name, for example: historic_map.jp2.

STEP 2. START QGIS, CREATE A NEW PROJECT AND ADD A WEB BASEMAP 

A. Open QGIS and create a new project (Project > Save As) in the same folder where you saved your
historic map image. Call the project Georeferencing.qgz.

B. Before adding layers to a project window, it is a good practice to start by setting the appropriate
projection (Project > Properties > CRS). Type in the following EPSG code into the Filter text box:
3857. This will allow you to select WGS 84 / Pseudo-Mercator projection from the automatically
displayed list of the predefined Coordinate Reference Systems (CRS). The EPSG: 3857 is a
commonly used global projection suitable for the display of the OSM basemap.

C. Click on the WGS 84 / Pseudo-Mercator and then click Apply. Note that the pink projection
window shown in the lower-right corner will automatically expand to a global extent. Click OK to
set the project CRS properties to EPSG: 3857 and close the CRS window.

http://www.loc.gov/resource/g3984bm.g3984bm_g044321914/?sp=1
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D. You can easily verify that the projection properties have been correctly updated. As shown in the 
figure below, the EPSG: 3857 is listed in the lower-right corner of the project window. That means 
that all geospatial layers added to this project will be transformed on-the-fly to match this global 
projection. More specifically, all layers will be displayed in the EPSG: 3857 coordinate system for 
the duration of the project. 
 

 
 

E. Add a standard web basemap to your project (Browser panel> XYZ tiles > OpenStreetMap > Add 
Layer to Project). OSM is a free-to-use map of the entire world created by volunteers and 
available under the open-content license. You will use this basemap as a source dataset to collect 
your GCPs.  
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F. Before starting the georeferencing process, it is a good practice to locate the same area on the 
source dataset (in this case, the OSM basemap) and the destination dataset (in this case, the 
historic fire insurance map). Zoom in to the area marked with a red square as shown in the figure 
below.  
 

 
 

G. More specifically, zoom in to the downtown area of Biloxi, Mississippi. Visually locate the 
following three intersections on the OSM basemap: Main Street and Bayview Avenue (point 1), 
Oak Street and Howard Avenue (point 2), and Seal Avenue and West Howard (point 3).  
 

 
 

H. Once you locate these intersections, it might be 
helpful to add a map bookmark for Downtown Biloxi. 
Georeferencing requires multiple, back-and-forth 
panning around the map. A bookmark will allow you 
to return to the exact same location on the OSM 
basemap. To create a bookmark, select View > New 
Spatial Bookmark. Name it Downtown_Biloxi, save it 
in Project Bookmarks, and click Save to create it.  
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I. At this point, it might be helpful to print the historic fire insurance map and mark the same 
intersections on the hard-copy map. This may be useful because some of the historic street 
names have changed over time. Note that the points are uniformly spread out on the historic 
map (destination dataset) and placed at intersections easily distinguishable on both maps.  

STEP 3. ADD THE HISTORIC MAP TO YOUR PROJECT  

A. Add the JEPG2000 file, downloaded in Step 1, to the project window (Layer > Add Layer >Add 
Raster Layer). Browse to the historic_map.jp2 raster dataset. Click Add to insert it to the project 
window.  
 

 
 

B. When attempting this step, you will see a yellow warning indicating that the CRS was undefined. 
At this time, disregard this warning and add the historic map layer to the project window anyway.  
 

 
 

C. Right-click on the recently added layer and click on the Zoom to Layer option. As you can see, the 
historic map layer does not overlap at all with the basemap.  
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D. This incorrect map placement should not be surprising as this layer does not have any geospatial 
information that can be used to position this image correctly. Right-click on the historic map layer 
and select Remove Layer.  
 

 
 

E. In the Browser window, find Spatial Bookmarks > Project Bookmarks. Click on the 
Downtown_Biloxi bookmark. This will return the map view to the previously defined extent.  
 



 
 

 

 

Georeferencing a Raster Dataset Using QGIS  Page 7 

 

 

STEP 4. COLLECT GROUND CONTROL POINTS 

A. To be able to georeference the historic map layer, you need to use the Georeferencer window. 
Open it by selecting it from the Raster menu (Raster > Georeferencer).  
 

 
 

B. The Georeferencer window will appear automatically on top of your project window. Since this 
window is separate from the project window, you can move it around your screen and resize it as 
needed. Once properly positioned, select Open Raster from the File menu on the Georeferencer 
window. 
 

 
 

C. Browse to the historic_map.jp2. The image will open to display the full map extent. Use the Zoom 
In, Zoom Out, and Pan tools to view details on the map.  
 



 
 

 

 

Georeferencing a Raster Dataset Using QGIS  Page 8 

 

 
 

D. Before collecting actual GCPs it is a good idea to make sure the table showing each recorded 
point is visible (View > Panels > GCP table).  
 

 
 

E. An empty GCP table panel will be added at the bottom of the Georeferencer window. Once you 
start adding your GCPs, this panel will gradually fill with pairs of coordinates for the source and 
destination datasets, as well as residual errors, calculated for each pair of coordinates.  
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F. Also, it is critically important to update available 
georeferencing settings (Settings > Transformation Settings). 
In the Transformation Settings dialog box, select Polynomial 1 
as the Transformation type. This is a simple transformation 
involving only shifting, rotating, and/or resizing. Under the 
Output raster, create a new raster dataset called 
hist_map_gr.tif and save it in the same folder as your 
historic_map.jp2 file. Make sure that the box to Load in QGIS 
when done is checked. This way, the newly georeferenced 
raster dataset will be automatically added to your project 
window. You can keep the default options for the remaining 
parameters.  

G. Now, you are ready to collect your first GCP. Select the Add 
Points tool from the toolbar in the Georeferencer window. 
 

 
 

H. On the historic map, move the cursor over the corner of Main Street and Bayview Avenue (note 
that the old street name is Back Bay Avenue). This will be your first GCP. When you click the left 
mouse button on that location (be accurate), the following window will appear: 
 

 
 

I. On the Enter Map Coordinates window, click the From Map Canvas option, and select the same 
street corner on the OSM basemap.  

J. Once the GCP is collected the coordinates from the georeferenced dataset will automatically 
appear in the Enter Map Coordinates window.  
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K. When you click OK the GCP will be created and displayed in the GCP table. The X,Y coordinates 
for the source and destination datasets will be listed. 
 

 
 

L. In addition to listing the source and destination coordinates in the GCP table, the control point is 
marked on the source map with a small red marker. Verify that you can see this point on your 
basemap and that it is in a proper location.  
 

 
 

M. Repeat this process for the other two locations, as indicated in Step 2G. Start with the corner of 
Oak Street and Howard Avenue, and next move on to Seal Avenue and West Howard. Remember, 
you can always use the project bookmark to return to the original downtown Biloxi extent on the 
OSM basemap. At first, it may be counterintuitive to work in two separate windows on the same 
task, but after you collect the first few points the process should become easier.  

N. After you successfully collect three points, your table should look similar to the one shown below. 
Note that your coordinates and residual errors might be slightly different.  
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O. For practice purposes, you are welcome to collect a few additional points. In fact, typically more 
than three points are collected to ensure good image registration quality. However, for the 
purpose of this tutorial you can successfully georeference a raster dataset using just three points.  

P. If you make a mistake, you can easily delete erroneous GCPs. To delete a pair of GCPs, select the 
Delete GCP tool and click on the point to be deleted. Alternatively, in a GCP table click on one of 
the cells for the GCP you want to delete, and then right-click and select remove. 

Q. When you are satisfied with the GCPs placement, select the green arrow on the Georeferencer 
toolbar to Start Georeferencing. 
 

 
 

R. If done correctly, this process should not take long to complete. As shown in the figure below, the 
georeferenced historic map will be automatically added to your project window, and this time 
will be placed in the correct geographic space.  
 

 
 

S. You can zoom in and out to examine how well the historic map overlaps with the current OSM 
basemap. You can also change transparency of the layer to verify how the interior sections of the 
map are matching or how much the road network has changed over time.  

T. If you are satisfied with the georeferencing, close the Georeferencer window. When prompted to 
save the GCP table, click Yes. A file with the same name as the scanned historic map will be 
created, with the word 'points' appended to the file name. 
 

This concludes our GEO Tutorial. The historic fire insurance map of Biloxi has been successfully 
georeferenced. If you would like to improve the registration accuracy of the destination map, you 
have an option to generate additional control points. Make sure to distribute your control points 
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evenly throughout the historic map and avoid concentrating them in a single location. A valid 
approach is to start by creating four points, one at each map corner, and if the registration is still 
poor, add several more points, uniformly distributed within the interior portion of the destination 
map. 


